SWK Phone System Outage

Incident Report for SWK Technologies Systems

Resolved

Resolved – Phone Systems Operational

Following continued monitoring, all issues related to our third‑party phone service provider have been fully resolved. Our phone systems are fully operational, and normal service has been restored across the organization.

We appreciate your patience and understanding throughout this incident and thank you for your continued support.
Posted Apr 20, 2026 - 13:10 EDT

Monitoring

Phone System Update – Partial Restoration

SWK previously experienced a company-wide phone system outage due to an issue with a third-party service provider. Some functionality has now been restored, and our main support lines are open and operational.

While services are improving, some users may continue to experience intermittent issues as we actively monitor system stability and work with our vendor to ensure full restoration.

Please stand by for further updates. We appreciate your continued patience and understanding.
Posted Apr 20, 2026 - 11:11 EDT

Investigating

Phone System Outage:

SWK is currently experiencing a company-wide phone system outage due to an issue with a third-party service provider. We are actively working with the vendor to resolve the problem as quickly as possible.

During this time, our staff is unable to make or receive phone calls. Please direct all requests and communications through our email channels until service is restored.

We appreciate your patience and understanding.
Posted Apr 20, 2026 - 11:02 EDT
This incident affected: SWK Technologies Systems (SWK Phone Systems).