We have identified and resolved an issue that was affecting some clients' ability to connect to Parallels on the West Farm. A fix has been implemented and successfully validated by our team.
If you were experiencing difficulties accessing your hosted system, please try logging in again. Services should now be functioning normally.
We will continue to monitor the environment to ensure stability. If you are still unable to connect, please contact our support team for assistance.
Posted Jul 10, 2026 - 13:45 EDT
Update
We have restored access for many systems in the hosting environment. There are still several systems that are having issues connecting to Parallels. We're working diligently to diagnose the issue with the application vendor.
Posted Jul 10, 2026 - 12:54 EDT
Investigating
We have received reports of intermittent connectivity impacting application hosting clients on the west.goscs.com farm. We're actively investigating the issue.
Posted Jul 10, 2026 - 11:24 EDT
This incident affected: SWK MCS Data Centers (SWK MCS Data Center West).