Intermittent Network Connectivity
Incident Report for SWK Technologies Systems
Postmortem

Incident Summary

Wednesday 6/22/2023

9:30PM EDT: Maintenance began on our cluster monitoring and management systems.

11:30PM EDT: NOC team was notified by internal monitoring systems that a small number of systems were experiencing internet connectivity issues

Thursday 6/23/2023

12:12 AM EDT: Incident opened, and notice sent to clients declaring a partial system outage

1:15 AM EDT: Issue was identified as an errant addition of a DHCP server on a virtual network switch

1:25 AM EDT: DHCP server was removed from the virtual switch which had impacted some system network connectivity. Remediation work began to restore network connectivity and revert changes made.

1:45AM EDT: Remediation work concluded, and all impacted systems were re-connected and stable.

Impact

A small number of Virtual Machines in the cluster were provided erroneous network information, which caused their internet connectivity to be interrupted.

Root Cause

A routine change made to our cluster software resulted in an errant addition of a virtual network component. The change has been sandboxed and tested in an alternate environment and the issue is not able to be replicated.

Corrective Action

Information on this issue has been sent to the software vendor for further review. Updates to the cluster monitoring software have been rolled back and paused until feedback is received from the vendor.

Posted Jun 22, 2023 - 17:26 EDT

Resolved
The remediation work has concluded. All impacted systems are back online and available.
Posted Jun 22, 2023 - 01:45 EDT
Identified
The issue has been identified. Our team is in the process of remediating this problem now. At this time only a very small subset of systems are impacted.
Posted Jun 22, 2023 - 01:20 EDT
Investigating
There are reports that clients in our IAAS cluster are having intermittent connectivity problems. Our team is investigating the issue.
Posted Jun 22, 2023 - 00:12 EDT
This incident affected: SWK MCS Data Centers (SWK MCS Data Center East).