Update – Monitoring A remediation has been implemented, and we believe the issue has been resolved. At this time, services are operating normally.
This incident will remain open in a monitoring state through the close of business tomorrow to ensure stability and confirm that no further impact is observed.
We appreciate your patience and continued partnership.
Posted May 11, 2026 - 18:17 EDT
Identified
Incident Update – Intermittent Connectivity Degradation We have identified an issue with one of our upstream internet service providers that is intermittently impacting inbound connectivity. This may present to end users as increased latency, delayed response times, general slowness, or occasional disconnects.
Our team is actively engaged with the affected provider to isolate and remediate the issue. We will continue to monitor the situation closely and provide additional updates as more information becomes available.
We appreciate your patience and understanding while we work toward a resolution.
Posted May 11, 2026 - 16:40 EDT
Investigating
We have received reports of intermittent disconnects by some clients and we're currently investigating. Please stand by for further updates.
Posted May 11, 2026 - 15:18 EDT
This incident affects: SWK MCS Data Centers (SWK MCS Data Center East).