Parallels - System Access Issues

Incident Report for SWK Technologies Systems

Resolved

All redundancy to the Parallels systems has been restored,
Posted Apr 22, 2026 - 22:02 EDT

Identified

We've Identified and repaired an issue with the Parallels database. Access should be restored. We are working to restore redundancy at this time.
Posted Apr 22, 2026 - 21:53 EDT

Investigating

We are investigating reports of Parallels publishing issues. This may cause Parallels to display no available resources to connect to. We will update this incident once we have more information.
Posted Apr 22, 2026 - 21:45 EDT
This incident affected: SWK MCS Data Centers (SWK MCS Data Center West).